Mobile App Scanning
Incident Report for TechStatus
Resolved
This incident has been resolved.
Posted Dec 13, 2022 - 08:19 EST
Investigating
We are currently investigating an issue regarding invoice scans on the mobile application.
Posted Dec 12, 2022 - 15:01 EST
This incident affected: MarketMan Mobile.