Square POS Connection
Incident Report for TechStatus
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 11:28 EDT
Monitoring
As we update our system, Square customers may experience a pop-up asking to reconnect their POS system.
Please follow the prompt and connect.
Posted Aug 29, 2022 - 08:15 EDT
This incident affected: Point of Sale Integrations.